We want to remove ads from the website, but we need your help.
Please donate some of your computer power to running our website.

20. April 2017

VersionConflict when installing certbot

LetsEncrypt saved the web few years back with free SSL certificates and automation to generate and verify them made it easy for hobby servers to also gain their SSL certificates and https protection. It was all great and with some minor hickups (like buggy nginx setup), but once you lived over that it renewed it all perfectly. I like to keep my server quite up-to-date and so I have decided to download new version, which is now named certbot. All finely documented with some auto-installed script, but when I tried to run I have received

An unexpected error occurred:
VersionConflict: (acme 0.11.1 (/usr/lib/python2.7/dist-packages), Requirement.parse('acme==0.4.2'))
Please see the logfile 'certbot.log' for more details.

After going through the logs I have seen that acme 0.11.1 should be installed according to certbot, so where does the 0.4.2 version come from. It appears from previously installed letsencrypt packages. And keep reminded that it is not just one, so you need to run:

pip uninstall letsencrypt
pip uninstall letsencrypt-nginx

Now that you have it cleaned up you can upgrade certbot to newest version on pip (surprise, that apt-get version is so old? me too)

pip install --upgrade certbot

I am not happy by no option of installing it via source and only through packages, but as long as pip works as it should I will keep it updated over there.

Newest from this category: